JWK - Jackall's IT Wiki

Sécurité, Système, Réseau

Outils pour utilisateurs

Outils du site


cisco_nexus_fex

Nexus 5K Fabric Extender Link configuration

switch(config)# feature fex 
switch(config)# sh feature | i fex
fex                   1         enabled 
switch(config)# 
interface Ethernet1/1
  switchport mode fex-fabric
  fex associate 100

fex-fabric command line activate the link as a fabric extension port. You have to use a FET connector

How to check

5548_BAS(config-if)# sh fex detail 
FEX: 101 Description: test_fex_gauche   state: Image Download
  FEX version: 5.1(3)N2(1b) [Switch version: 5.1(3)N2(1)]
  FEX Interim version: 5.1(3)N2(1b)
  Switch Interim version: 5.1(3)N2(1)
  Module Sw Gen: 12594  [Switch Sw Gen: 21]
  post level: complete
 pinning-mode: static    Max-links: 1
  Fabric port for control traffic: Eth1/1
  FCoE Admin: false
  FCoE Oper: true
  FCoE FEX AA Configured: false
  Fabric interface state:
    Eth1/1 - Interface Up. State: Active
  Fex Port        State  Fabric Port
Logs:
04/04/2013 08:12:56.84123: Module register received
04/04/2013 08:12:56.85200: Image Version Mismatch
04/04/2013 08:12:56.85578: Registration response sent
04/04/2013 08:12:56.85843: Requesting satellite to download image
5548_BAS(config-if)# sh fex 
  FEX         FEX           FEX                       FEX               
Number    Description      State            Model            Serial     
------------------------------------------------------------------------
101  test_fex_gauche                Online   N2K-C2248TP-E-1GE   SXXXXXX

<note important> Fex ID have to be unique!! </note>

fex 100
  pinning max-links 1
  description "fex_droite_bas"
fex 101
  pinning max-links 1
  description "test_fex_gauche"

interface Ethernet1/1
  switchport mode fex-fabric
  fex associate 101

interface Ethernet1/2
  switchport mode fex-fabric
  fex associate 100

How to check

5548_BAS# sh fex 
  FEX         FEX           FEX                       FEX               
Number    Description      State            Model            Serial     
------------------------------------------------------------------------
100  fex_droite_bas                Online   N2K-C2248TP-E-1GE   SSI163905PA
101  test_fex_gauche                Online   N2K-C2248TP-E-1GE   SSI163905PE

Work just as a single link Fex, but you have to use a Port channel

interface Ethernet1/1
  channel-group 101
interface Ethernet1/2
  channel-group 101
  • Configure Port channel
interface port-channel101
  switchport mode fex-fabric
  fex associate 101

How to check

switch(config-if)# sh fex detail 
FEX: 101 Description: FEX0101   state: Online
  FEX version: 5.1(3)N2(1) [Switch version: 5.1(3)N2(1)]
  FEX Interim version: 5.1(3)N2(1)
  Switch Interim version: 5.1(3)N2(1)
  Extender Serial: SSI163905PE
  Extender Model: N2K-C2248TP-E-1GE,  Part No: 73-13671-01
  Card Id: 149, Mac Addr: 68:86:a7:9c:4f:82, Num Macs: 64
  Module Sw Gen: 12594  [Switch Sw Gen: 21]
  post level: complete
 pinning-mode: static    Max-links: 1
  Fabric port for control traffic: Eth1/1
  FCoE Admin: false
  FCoE Oper: true
  FCoE FEX AA Configured: false
  Fabric interface state:
    Po101 - Interface Up. State: Active
    Eth1/1 - Interface Up. State: Active
    Eth1/2 - Interface Up. State: Active
<...>

Tests

Removing 1 link from a PO is not a problem!!

Removing all links :

  • no more data (of course)
  • adding back previously removed link ⇒ fex link goes up again

Remote Fex switch port configuration

Conf t
! Int EthFEXID/module/Port
interface Ethernet101/1/1
  switchport access vlan 2
  spanning-tree port type edge

Where

  • FEXID is the ID assigned to the fex switch
  • module is always 1 on 2248

search?q=Cisco%20Nexus5000%20FEX%20Configuration%20%20Networking%20en&amp;btnI=lucky

cisco_nexus_fex.txt · Dernière modification: 2018/02/18 16:01 (modification externe)