JWK - Jackall's IT Wiki

Sécurité, Système, Réseau

Outils pour utilisateurs

Outils du site


cisco_nexus_vpc_configuration

Cisco Nexus VPC configuration

Principe

  • VPC domain ~= vtp domain : information exchange
  • Vpc keepalive : information exchange on VPC for synchro (require a VPC domain)
  • Vpc peer link : VPC link for data traffic ( inter N5K)

Single sided VPC

Requirement

Feature vpc
Feature fex
Feature lacp 

VPC keepalive interface

  • Nexus H
interface mgmt0
  vrf member management
  ip address 10.100.1.1/24
  • Nexus B
interface mgmt0
  vrf member management
  ip address 10.100.1.2/24

VPC domain configuration

  • Nexus H
vpc domain 100
peer-keepalive destination 10.100.1.2 source 10.100.1.1 vrf management
  • Nexus B
vpc domain 100
peer-keepalive destination 10.100.1.1 source 10.100.1.2 vrf management

Validation

N5K_HAUT(config)# show vpc peer-keepalive 

vPC keep-alive status             : peer is alive                 
--Peer is alive for             : (2690) seconds, (468) msec
--Send status                   : Success 
--Last send at                  : 2009.03.21 07:44:02 780 ms
--Sent on interface             : mgmt0
--Receive status                : Success
--Last receive at               : 2009.03.21 07:44:02 780 ms
--Received on interface         : mgmt0
--Last update from peer         : (0) seconds, (291) msec

vPC Keep-alive parameters
--Destination                   : 10.100.1.2
--Keepalive interval            : 1000 msec
--Keepalive timeout             : 5 seconds
--Keepalive hold timeout        : 3 seconds
--Keepalive vrf                 : management
--Keepalive udp port            : 3200
--Keepalive tos                 : 192
  • Nexus H
Interface e1/31-32
Channel-group 4096 mode on 
interface port-channel4096
  spanning-tree port type network
  speed 10000
  vpc peer-link
  • Nexus B
Interface e1/31-32
Channel-group 4096 mode on 
interface port-channel4096
  spanning-tree port type network
  speed 10000
  vpc peer-link

Validation

N5K_HAUT(config)# show vpc br
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 100 
Peer status                       : peer adjacency formed ok      
vPC keep-alive status             : peer is alive                 
Configuration consistency status  : success 
Per-vlan consistency status       : success                       
Type-2 consistency status         : success 
vPC role                          : secondary                     
Number of vPCs configured         : 0   
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans    
--   ----   ------ --------------------------------------------------
1    Po4096 up     1                         

FEX Switch configuration

<note important>VPC can only be applied on a port channel !!!</note>

  • Nexus H
interface Ethernet1/1
   channel-group 101 mode on 
interface port-channel101
  description fex vers FEX
  switchport mode fex-fabric
  fex associate 101
  vpc 101
  • Nexus B
interface Ethernet1/1
   channel-group 101 mode on 
interface port-channel101
  description fex vers FEXSWdroite
  switchport mode fex-fabric
  fex associate 101
  vpc 101
cisco_nexus_vpc_configuration.txt · Dernière modification: 2018/02/18 16:01 (modification externe)